PHP and MySQL:

As of WordPress 3.2, you’ll need to be running PHP 5.2.4 and MySQL 5.0. Log in to your hosting account, and check to make sure you have at least  PHP 5.2.4 and MySQL 5.0.

Health Check plugin to confirm your PHP & MySQL settings:

If you don’t know how to find this information in your hosting account or you don’t even know how to access your hosting control panel because someone else manages that for you, don’t fret. You can find out if you’re ready for 3.2 with the Health Check plugin. In your dashboard, go to Plugins > Add New and search for “health check” (it should be the first result). Install it, activate it, and it will tell you if you need to update anything.

Read full article: Are You Ready for WordPress 3.2?